Cisco CCNA Troubleshooting Mastery

50 CCNA troubleshooting exercises to help you master the CCNA material.

$29 $39

In this course, you'll get 50 individual troubleshooting exercises that cover every configuration concept on the Cisco CCNA exam, including:

  • Access Control Lists
  • OSPF
  • NAT
  • DHCP
  • NTP
  • SSH
  • Switch Configuration
  • IPv6
  • VLANs
  • Static Routing

Each exercise gives you background information, a task, a topology, and command output.  Your task is to determine where the error is located.  By learning how to troubleshoot Cisco CCNA configurations like these, you'll be able to handle the performance-based questions that you may see on the Cisco CCNA exam.  Here's an example:

Background Information:  A single router corporate network has been experiencing network connectivity issues.

Task:  Use the output from the troubleshooting commands to identify the two configuration errors.

AccountingGateway#show running-config

Building configuration...

Current configuration : 722 bytes

!

version 15.1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname AccountingGateway

!

ip cef

no ipv6 cef

!

spanning-tree mode pvst

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

shutdown

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/2

ip address 10.0.0.1 255.255.255.0

duplex auto

speed auto

shutdown

!

interface Vlan1

no ip address

shutdown

!

end


After careful review, you may have located the two issues - there is no interface configured for the 192.168.1.0/24 network, and interface G0/2 is shut down.  See below to see what we’re specifically looking for:


AccountingGateway#show running-config

Building configuration...

Current configuration : 722 bytes

!

version 15.1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname AccountingGateway

!

ip cef

no ipv6 cef

!

spanning-tree mode pvst

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

shutdown

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/2

ip address 10.0.0.1 255.255.255.0

duplex auto

speed auto

shutdown

!

interface Vlan1

no ip address

shutdown

!

end

Having a mastery of concepts like this is critical for your success on the Cisco CCNA, and will make you a much better network administrator.  If you want to be truly prepared for the Cisco CCNA exam, sign up for CCNA Troubleshooting Mastery now.

$29 $39

To receive instant access, click the purchase button below.

Have questions?  Email me at matt@startacybercareer.com.